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Creating Web Pages with SeaMonkey Composer
SeaMonkey Composer lets you create your own web pages and publish them on the web. You don't have to know HTML
to use Composer; it is as easy to use as a word processor.

Toolbar buttons let you add lists, tables, images, links to other pages, colors, and font styles. You can see what your
document will look like on the Web as you create it, and you can easily share your document with other users, no matter
what type of browser or HTML-capable email program they use.

To start using SeaMonkey Composer:

Click the Composer icon in the lower-left corner of any SeaMonkey window.

Composer icon

In this section:
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Starting a New Page
In this section:

Creating a New Page
Saving and Browsing Your New Page

Creating a New Page
SeaMonkey Composer is an HTML (Hypertext Markup Language) editor that allows you to create and edit web pages.
Composer is a WYSIWYG (What You See Is What You Get) editor, so you can display how your page will look to the
reader as you're creating it. It is not necessary for you to know HTML, since most of the basic HTML functions are
available as commands from the toolbars and menus.

Composer also lets you edit the HTML source if you want. To view or edit the HTML source code, open the View menu,
and choose HTML Source, or click the <HTML> Source tab in the Edit Mode toolbar at the bottom of the Composer
window.

To create a web page, use one of the methods described below. Once you've started a page, you can add and edit text
just as you would in a word processor.

To create a new page from the Navigator browser:
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Open the File menu, choose New, and then Composer Page. A Composer window containing a blank page opens.

To edit a page you're currently browsing in Navigator:

In the Navigator window of the page you're viewing, open the File menu and choose Edit Page. You see a
Composer window that contains the page you're viewing.

To create a new page in Composer:

Click the New button in Composer's toolbar.

To start from an HTML file stored on your local drive:

Open the Window menu and choose Composer. You see the Composer window.1.
Open the File menu and choose Open File. You see the Open HTML File dialog box.2.
On your local drive, locate the file that you want to edit.3.
Click Open to display the specified file in a Composer window.4.

To edit a web page:

Open the Window menu and choose Navigator.1.
Go to a web page: type the URL of the page (for example, http://www.mozilla.org) in the Location Bar 
and press Return.

2.

Open the File menu and choose Edit Page.3.

Tip: In the Composer window you can quickly open the most recent file you've been working on by opening the File
menu, choosing Recent Pages, and then selecting the file you want from the list.

[Return to beginning of section]

Saving and Browsing Your New Page
You can save Composer documents in HTML or text-only format. Saving a document in HTML format preserves the
document's formatting, such as text styles (for example, bold or italic), tables, links, and images. Saving a document in
text-only format removes all the HTML tags but preserves the document's text.

To save a document as an HTML file:

Open the File menu and choose Save or click the Save button on the Composition toolbar.
If you haven't already given your page a title, Composer prompts you to do so. Composer displays the page title
in the browser window's title bar when you view the page in the browser. The document's page title also appears
in your list of bookmarks if you bookmark the page.

Composer then prompts you to enter a filename and specify the location where you want to save the file. Make
sure you preserve the .html extension in the filename.

To change the filename or location of an existing HTML file:

Choose Save As and select a different filename or location.

When you save a page in Composer, all parts of the page (the HTML, images and other files, such as sound files and
style sheets), are saved locally on your hard drive. If you only want to save the HTML part of the page, you must change
the Composer preference for saving pages. See Composer Preferences - Composer for more information on changing
Composer's setting for saving pages.

If an image location is absolute (starts with “http://”) and you are connected to the Internet, you will still see that image in
the document in Composer and Navigator. However, if the image location is relative to the page location (starts with
“file:///”), then you won't see the image in the local version of the document.

To save a document as a text-only file:

Open the File menu and choose Export to Text.1.
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Enter the filename and specify the location where you want to save the file.2.

Note: Images do not appear in documents saved in the text-only format.

Tip: You can choose Revert to Last Saved from the File menu to retrieve the most recently saved copy of the document
in which you're working. Keep in mind that your current changes will be lost.

To view your page in a browser window in order to test your links:

Open the File menu and choose Browse Page (or click Browse in the Composition toolbar). If you have not yet
saved your document, Composer prompts you to enter a page title, filename, and location. The Composer window
remains open behind the new Navigator window.

[Return to beginning of section]

Formatting Your Web Pages

In this section:

Formatting Paragraphs, Headings, and Lists
Working with Lists
Changing Text Color, Style, and Font
Removing or Discontinuing Text Styles
Finding and Replacing Text
Inserting Horizontal Lines
Inserting Special Characters
Inserting HTML Elements and Attributes
Validating the HTML
Choosing the Right Editing Mode

Formatting Paragraphs, Headings, and Lists
To apply a format to a paragraph, begin from the Composer window:

Click to place the insertion point where you want the format to begin, or select the text you want to format.1.
Choose a paragraph format using the drop-down list in the Format toolbar:

Body Text: Applies the application default font and style for regular text, without affecting the spacing
before or after the text.
Paragraph: Inserts a paragraph tag (use this to begin a new paragraph). The paragraph includes top
and bottom margins.
Heading 1 - Heading 6: Formats the paragraph as a heading. Heading 1 is the highest-level heading,
while Heading 6 is the lowest-level heading.
Address: Can be used for a web page “signature” that indicates the author of the page and the person to
contact for more information, for example: user@example.com

You might want to include the date and a copyright notice. This format usually appears at the bottom of
the web page under a horizontal line. Navigator displays the address format in italics.

Preformat: This is useful for elements such as code examples, column data, and mail messages that
you want displayed in a fixed-width font. In normal text, most browsers remove extra spaces, tabs, and
paragraph returns. However, text that uses the Preformatted style is displayed with the white space
intact, preserving the layout of the original text.

2.

To format text as a heading:

Click to place the insertion point anywhere within the text that you want to format.1.
Using the drop-down list in the Format toolbar, choose the level of heading you want, from 1 (largest) to 62.
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(smallest). Choose “Heading 1” for your main heading, “Heading 2” for the next level, and so forth.

To apply a list item format:

Click to place the insertion point within the line of text that you want to format.1.
Open the Format menu and choose List.2.
Choose the list style:

Bulleted: Each item has a bullet (dot) next to it (as in this list).
Numbered: Items are numbered.
Term and Definition: These two styles work together, creating a glossary-style appearance. Use the
Term tag for the word being defined, and the Definition tag for the definition. The Term text appears flush
left, and the Definition text appears indented.

3.

Tip: You can quickly apply a list style to a block of text by selecting the text and clicking the Numbered List  or

Bulleted List  buttons on the Format toolbar.

To change the style of bullets or numbers:

Click to place the insertion point within the text of the list item you want to change, or select one or more items in
the list if you want to apply a new style to the entire list.

1.

Open the Format menu and choose List Properties.2.
Select a bullet or number style from the drop-down list. For numbered lists, you can specify a starting number.
For bulleted lists, you can change the bullet style.

3.

Tip: You can also double-click on a bullet or number in a list to display the List Properties dialog box.

To align a paragraph or text in your page, for example, centering or aligning to the left or right:

Click to place the insertion point within the paragraph or line of text you want to align.1.
Open the Format menu and choose Align; then choose an alignment option.2.

Note: You can also use the Format toolbar to align text.

[Return to beginning of section]

Working with Lists
To end a list and continue typing body text:

Click to place the insertion point at the end of the last list item and press Return twice to end the list.

To change one or more list items to body text:

Click to place the insertion point within the list item, or select the list items.1.
In a numbered list, click the numbered list button (or in a bulleted list, click the bulleted list button) in the Format
toolbar.

2.

To position indented text below a list item:

Click to place the insertion point within the list item.1.
Press Shift+Returnto create the hanging indent.2.
Type the text you want to indent.3.
Press Shift+Return to create another indented paragraph, or press Return to create the next list item.4.

Tip: You can increase or decrease the indentation of list items by clicking anywhere in a list item and then clicking the
Indent or Outdent button on the Format toolbar. Alternatively, click anywhere in a list item and press Tab to indent one 
level. Press Shift+Tab to outdent one level.

To merge two adjacent lists:
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Select the two lists that you want to merge. Be sure to select all of the elements in both lists. Note that any text in
between the two lists will also become part of the merged list.

1.

Click the bulleted or numbered list button in the Format toolbar to merge the lists.2.

[Return to beginning of section]

Changing Text Color, Style, and Font
To change the style, color, or font of selected text:

Select the text you want to format.1.
Open the Format menu and choose one of the following:

Font: Use this to choose a font. If you prefer to use fonts specified by the reader's browser, select
Variable Width or Fixed Width.

Note: Not all fonts installed on your computer appear. Instead of specifying a font that may not be
available to all who view your web page, it's generally best to select one of the fonts provided in the menu
since these fonts work on every computer. For example, the fonts Helvetica, Arial, Times, and Courier
generally look the same when viewed on different computers. If you select a different font, it may not look
the same when viewed using a different computer.

Size: Use this to choose a relative font size or select an option to increase or decrease text size
(relative to the surrounding text).
Text Style: Use this to select a style, such as italic, bold, or underline, or to apply a structured style,
for example, Code.
Text Color: Use this to choose a color from the color picker. If you are familiar with HTML hexadecimal
color codes, you can type a specific code or you can just type a color name (for example, “blue”). You'll 
find the official W3C list of CSS supported color names here , and another list of commonly supported
color names here .

2.

To change the background color of the page:

Click anywhere in the page.1.
Click the background color block in the Format toolbar.2.
Choose a background color from the Block Background Color dialog box.3.
Click OK.4.

Tip: To quickly change the color of text to the color last used, select the text, then press Shift and click on the text color
block in the Format toolbar. This is useful when you want to use one color for separate lines of text.

You can also use an image as a background. See Setting Page Colors and Backgrounds.

[Return to beginning of section]

Removing or Discontinuing Text Styles
To remove all text styles (bold, italic, and so on) from selected text:

Select the text.1.
Open the Format menu and choose Remove All Text Styles.2.
Continue typing.3.

To continue typing text with all text styles removed:

Place the insertion point where you want to discontinue the text styles.1.
Open the Format menu and choose Discontinue Text Styles.2.
Continue typing.3.

[Return to beginning of section]
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Finding and Replacing Text
To find text in the page you're currently working on:

Click to place the insertion point where you want to begin your search.1.
Open the Edit menu and choose Find and Replace. You see the Find and Replace dialog box.2.
Type the text you want to locate in the “Find what” field. To narrow the search, check one or more of the following
options:

Match upper/lower case: Use this to specify whether the search is for case-sensitive text.
Wrap around: Use this to search to the end of the page and then start again from the top or bottom,
depending on whether you are searching forward or backwards.
Search backwards: Use this to search back from the insertion point to the beginning of the page.

3.

Click Find Next to begin searching. When Composer locates the first occurrence of the text, click Find Next to
search for the next occurrence.

4.

Click Close when you are done.5.

To find and replace text in the page you're currently working on:

Click to place the insertion point where you want to begin your search.1.
Open the Edit menu and choose Find and Replace. You see the Find and Replace dialog box.2.
Type the text you want to find and then type the replacement text.3.
To narrow the search, check one or more of the following options:

Match upper/lower case: Use this to specify whether the search is for case-sensitive text. If you
don't select this option, the search will find matching text in both upper and lower case.
Wrap around: Use this to search to the end of the page and then start again from the top.
Search backwards: Use this to search from the end to the beginning of the page.

4.

Click Find Next to search for the next occurrence. Composer selects the next occurrence of the text.5.
Click Replace to replace the selected text with the replacement text. Click Replace and Find to replace the
selected text and find the next occurrence. Click Replace All to replace every occurrence in the document with
the replacement text.

6.

Click Close when you are done.7.

[Return to beginning of section]

Inserting Horizontal Lines
Horizontal lines are typically used to separate different sections of a document visually. To insert a horizontal line (also
called a rule) in your page, begin from the Composer window:

Click to place the insertion point where you want the line to appear.1.
Open the Insert menu and choose Horizontal Line.2.

Setting Horizontal Line Properties

You can customize a line's height, length, width, alignment, and shading.

Double-click the line to display the Horizontal Line Properties dialog box.1.
Edit any of these properties:

Width: Enter the width and then choose “% of window” or “pixels”. If you specify width as a percentage,
the line's width changes whenever the Composer window's or browser window's width changes.
Height: Type a number for the line's height (in pixels).
3-D Shading: Select this to add depth to the line by adding a bevel shading.
Alignment: Specify where you want to place the line (left, center, or right).

2.

Click Use as Default to use these settings as the default the next time you insert a horizontal line.3.
To edit the properties of a horizontal line manually, click Advanced Edit. See the section, Advanced Property 
Editor, for details.

4.
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Tip: You can select “HTML Tags” from the View menu to show all the HTML elements in yellow boxes. Click any yellow
box to select everything within that HTML tag or element. Double-click any yellow box to display the Advanced Property 
Editor dialog box for that HTML tag or element.

[Return to beginning of section]

Inserting Special Characters
To insert special characters such as accent marks, copyrights, or currency symbols:

Click to place the insertion point where you want the special character to appear.1.
Open the Insert menu and choose Characters and Symbols. You see the Insert Character dialog box.2.
Select a category of characters.

If you choose Accent Uppercase or Accent Lowercase, then open the Letter drop-down list and select
the letter you wish to apply an accent to. (Note: not all letters have accented forms.) Select Common
Symbols to insert special characters such as copyright symbols or fractions.

3.

From the Character drop-down list, select the character you want to insert.4.
Click Insert.
You can continue typing in your document (or in a mail compose window) while you keep this dialog box open, in
case you want to use it again.

5.

Click Close when you are done inserting special characters.6.

[Return to beginning of section]

Inserting HTML Elements and Attributes
If you understand how to work with HTML source code, you can insert additional tags, style attributes, and JavaScript
into your page. If you are not sure how to work with HTML source code, it's best not to change it. To work with HTML
code, use one of these methods:

Place the insertion point where you want to insert the HTML code, or select the text you want to edit, and then
open the Insert menu and choose HTML. In the Insert HTML dialog box, enter HTML tags and text, and then click
Insert.
Select an element such as a table, named anchor, image, link, or horizontal line. Double-click the element to
open the associated properties dialog box for that item. Click Advanced Edit to open the Advanced Property
Editor. You can use the Advanced Property Editor to add HTML attributes, JavaScript, and CSS to objects.
Open the View menu, and choose HTML Source, or click the <HTML> Source tab in the Edit Mode toolbar at the
bottom of the Composer window. (If you don't see the Edit Mode toolbar, open the View menu and choose
Show/Hide; then make sure the Edit Mode Toolbar is checked.)

Using the Advanced Property Editor

To add HTML attributes and JavaScript to objects such as tables, images, and horizontal lines, you can use the
Advanced Property Editor.

Note: Unless you clearly understand how to add, delete, or modify HTML attributes and their associated values, it's
best not to do so.

If you are not currently viewing the Advanced Property Editor dialog box, follow these steps:

From the View menu (or the Edit Mode toolbar), choose HTML Tags.1.
Double-click the object that you want to modify to open its Properties dialog box.2.
Click Advanced Edit to open the object's Advanced Property Editor. The Advanced Property Editor has three
tabs, each of which lists the current properties for the selected object:

HTML Attributes: Click this tab to view or enter additional HTML attributes.
Inline Style: Click this tab to view or enter additional CSS (cascading style sheet) properties through

3.
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the <style> attribute. For more information on using CSS styles in Composer, see Composer Preferences 
-Composer.
JavaScript Events: Click this tab to view or enter JavaScript events.

To edit a property or attribute in any of the three lists, select the attribute you want to edit. You can then edit the
attribute's name or value using the editable Attribute and Value fields at the bottom of the dialog box. To add a
new attribute, type it in the Attribute field at the bottom of the dialog box. The new attribute is automatically added
when you click in the Value field. To remove an attribute, select it in the list, and click Remove Attribute.
Note: Required attributes are highlighted in the Attribute list.

4.

Click OK to apply your changes to the Advanced Property Editor dialog box.5.
Click OK again to exit the Properties dialog box.6.

Composer automatically places quotation marks around any attribute text.

[Return to beginning of section]

Validating the HTML
Before you put your document on a web server so that others can see it, you should first check the document's HTML
formatting to make sure it conforms to web standards. Documents containing validated HTML are less likely to cause
problems when viewed by different browsers. Just visually checking your web pages in Navigator doesn't ensure that
your document will appear correctly when viewed in other web browsers.

Composer provides a convenient way for you to check that your document conforms to W3C (World Wide Web
Consortium) HTML standards. Composer uses the W3C HTML Validation Service, which checks your document's HTML
syntax for compliance with HTML 4.01 standards. This service also provides information on how to correct errors.

Note: You must be connected to the Internet to use this feature.

To validate your document's HTML syntax:

Open the Tools menu, and choose Validate HTML. If you have unsaved changes, Composer asks you to save
them before proceeding.

1.

When the W3C HTML Validation Service page appears, click Browse and locate the file on your hard disk that you
want to validate.

2.

Click “Validate this document”.3.

[Return to beginning of section]

Choosing the Right Editing Mode
Typically, you won't need to change the editing mode from the default (Normal). However, if you want to work with the
document's HTML source code, you may want to change editing modes.

Composer allows you to quickly switch between four editing modes or views. Each editing mode allows you to continue
working on your document, but displays varying levels of HTML tags (and tag icons).

Before you choose an editing mode:

Open the View menu, choose Show/Hide, and then make sure there is a checkmark next to Edit Mode Toolbar.

The Edit Mode toolbar has four tabs:

Normal: Choose this editing mode to see how the document will look online while you are creating it. Choose this
mode to show table borders and named anchor icons. All other HTML tag icons are hidden.
HTML Tags: Choose this mode to show all HTML tag icons.
<HTML> Source: Choose this mode to view and edit the document as unformatted HTML source code. When
you save the document, the Normal mode reappears.
Preview: Choose this mode to display and edit the document exactly as it would appear in a browser window,
except that links and JavaScript functions will not be active.
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Note: JavaScript functions, frames, links, Java, embedded objects and animated GIF files are not active in any of the
editing modes. To display these items in their active state, click the Browse button on the Composition toolbar to load
the page into a browser window.

[Return to beginning of section]

Adding Tables to Your Web Page

In this section:

Inserting a Table
Changing a Table's Properties
Adding and Deleting Rows, Columns, and Cells
Selecting Table Elements
Moving, Copying, and Deleting Tables
Converting Text into a Table

Inserting a Table
Tables are useful for organizing text, pictures, and data into formatted rows and columns. To insert a table:

Click to place the insertion point where you want the table to appear.1.

Click the Table button  on the Composition toolbar. The Insert Table dialog box appears.2.
Type the number of rows and columns you want.

(Optional) Enter a size for the table width, and select either percentage of the window or pixels.
3.

Enter a number for the border thickness (in pixels); enter zero for no border.
Note: Composer uses a red dotted line to indicate tables with a zero border; the dotted line disappears when the
page is viewed in a browser.

4.

To apply additional table attributes or JavaScript, click Advanced Edit to display the Advanced Property Editor.5.
Click OK to confirm your settings and view your new table.6.

To change additional properties for your new table, see Changing a Table's Properties.

Tip: To insert a table within a table, open the Insert menu and choose Table.

[Return to beginning of section]

Changing a Table's Properties
This section describes how to modify properties that apply to an entire table as well as the rows, columns, or individual
cells within a table. If you are not currently viewing the Table Properties dialog box, follow these steps:

Select the table, or click anywhere inside it.1.

Click the Table button  on the toolbar, or open the Table menu and choose Table Properties. The Table
Properties dialog box contains two tabs: Table and Cells.

2.

Click the Table tab to edit these properties:
Size: Use this to specify the number of rows and columns. Enter the width of the table and then choose
“% of window” or “pixels”. If you specify width as a percentage, the table's width changes whenever the
Composer window's or browser window's width changes.
Borders and Spacing: Use this to specify, in pixels, the border line width, the space between cells,
and the cell padding (the space between the contents of the cell and its border).

3.
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Note: Composer uses a dotted outline to display tables with a zero border; the dotted line disappears
when the page is viewed in a browser.

Table Alignment: Use this to align the table within the page. Choose an option from the drop-down list.
Caption: Choose the caption placement from the drop-down list.
Background Color: Use this to choose a color for the table background, or leave it as transparent.

To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced Property
Editor.

4.

Click Apply to preview your changes without closing the dialog box, or click OK to confirm them.5.

To view, change, or add properties for one or more cells:

Select the row, column, or cell, then open the Table menu and choose Table Properties. The Table Properties
dialog box appears.

1.

Click the Cells tab to edit the following properties:
Selection: Choose Cell, Row, or Column from the drop-down list. Click Previous or Next to move through
rows, columns, or cells.
Size: Type a number for Height and Width, and then choose “% of table” or “pixels”.
Content Alignment: Select a vertical and horizontal alignment type for the text or data inside each
cell.
Cell Style: Select Header from the drop-down list for column or row headers (which centers and bolds
the text in the cell); otherwise choose Normal.
Text Wrap: Select “Don't wrap” from the drop-down list to keep text from wrapping to the next line
unless you insert a paragraph break. Otherwise, choose Wrap.
Background Color: Select a color for the cell background or leave it as transparent.

Note: To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced 
Property Editor

2.

Click Apply to preview your changes without closing the dialog box, or click OK to confirm them.3.

Tip: To change the text color or background color of one or more selected cells or the entire table, select the cells or
click anywhere in the table and then click the text color or background color icon in the Format toolbar.

Tip: To change the color of cells to the color last used, select the cell, then press Shift and click on the background
color picker. This is useful when you want to use one color for individual cells.

[Return to beginning of section]

Adding and Deleting Rows, Columns, and Cells
Composer allows you to quickly add or delete one or more cells, columns, or rows in a table. In addition, you can set
options that allow you to maintain the original rectangular structure or layout of the table while you perform editing tasks.

To add a cell, row, or column to your table:

Click inside the table where you want to add a cell (or cells).1.
Open the Table menu and then choose Insert.2.
Choose one of the cell groupings. (You can also insert a new table within a table cell.)3.

To delete a cell, row, or column:

Click a row, column, or cell to place the insertion point. Or, select neighboring cells to delete more than one row at
a time. To select neighboring cells, drag over the cells you want to select. To select individual cells in a table,
hold down the Cmd key and click on the cells you want to select.

1.

Open the Table menu and choose Delete.2.
Choose the item you want to delete.3.

To join (or merge) a cell with the cell on its right:

Click inside the cell on the left, open the Table menu, and choose Join with Cell to the Right.
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To join (or merge) adjacent cells:

Select adjacent cells by dragging over them.
Open the Table menu, and choose Join Selected Cells.

To split a joined cell back into two or more cells:

Click inside the joined cell, open the Table menu, and then choose Split Cell. Composer puts the entire contents
of the joined cell into the first of the two cells.

Refer to Selecting Table Elements for information on how to select non-adjacent cells, rows, and columns.

Changing the Default Table Editing Behavior

By default, when you delete one or more cells, Composer preserves the table's structure by adding cells at the end of a
row, wherever needed. This allows you to delete one or more cells but still maintain the table's original rectangular layout,
or structure. Otherwise, deleting cells can result in a table with empty spaces, or whose outline appears irregular due to
an uneven number of cells.

To change the default table editing behavior, begin from the Composer window:

Open the Edit menu, choose Preferences, and then choose Composer.1.
Under Table Editing, set the following preference:

Make sure that “Maintain table layout when inserting or deleting cells” is checked to ensure that you don't 
get an irregularly shaped table.

2.

Click OK.3.

See also Setting General Composer Preferences.

[Return to beginning of section]

Selecting Table Elements
You can use one of two ways to quickly select a table, cell, or group of cells:

Click in the table, open the Table menu, choose Select, and then choose an item from the submenu. For example,
to select a table, click anywhere inside the table, open the Table menu, choose Select, and then choose Table.
Or, you can use the mouse as a selection tool:

To select a group of adjacent cells: click in a cell, and then drag to select the cells you want. Drag the
mouse left or right to select a row; up or down to select a column.
To select non-adjacent cells: press Cmd and then click inside a cell. Keep pressing Cmd as you click to
select additional cells.
To extend a selection to include adjacent cells: click inside a cell and then drag over additional cells to
extend the selection.
To select one or more adjacent columns or rows: drag up or down to select the first column or row, and
then drag left or right to select additional adjacent columns or rows. Press Shift and drag to the right to
select an entire row. Press Shift and drag up or down to select an entire column.

[Return to beginning of section]

Moving, Copying, and Deleting Tables
To move a table:

Click inside the table.1.
Open the Table menu, choose Select, and then choose Table.2.

To copy or move the table: Use the Edit menu's cut, copy, and paste options.
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To delete the table: Open the Table menu again, choose Delete, and then choose Table.

[Return to beginning of section]

Converting Text into a Table
To convert text into a table:

Select the text that you want to convert into a table. Keep in mind that Composer creates a new table row for
each paragraph in the selection.

1.

Open the Table menu and choose Create Table from Selection. You see the Convert to Table dialog box.2.
Choose the character Composer uses to separate the selection into columns, or specify a different character to
use. If you choose Space as the separator for columns, choose whether or not you want Composer to ignore
multiple space and treat them as one space.

3.

Leave “Delete separator character” checked to have Composer remove the separator character when it converts
the text into a table. If you don't want Composer to delete the separator character, uncheck this option.

4.

Click OK.5.

Note: Text formatting is removed when the selected text is converted to a table.

[Return to beginning of section]

Adding Pictures (Images) to Your Web Page

In this section:

Inserting an Image into Your Page
Editing Image Properties

Inserting an Image into Your Page
You can insert GIF, JPEG, BMP, and PNG (Portable Network Graphics) images into your web page. You can also use
them to create links. When you insert an image, Composer saves a reference to the image in your page.

Note: If you plan to publish your pages to the web, it's best not to use BMP images in your pages.

Tip: It's best to first save or publish your page before you insert images into it. This allows Composer to automatically
use relative references to images once you insert them.

To insert an image:

Click to place the insertion point where you want the image to appear.1.

Click the Image button  on the toolbar, or open the Insert menu and choose Image. You see the Image
Properties dialog box.

2.

Type the location and filename of the image file, or click Choose File to search for an image file on your hard drive
or network.

3.

Type a simple description of your image as the alternate text that will appear in text-only browsers (as well as
other browsers) when an image is loading or when image loading is disabled.
Alternatively, you can choose not to include alternate text.

4.

If needed, click other tabs so you can adjust the settings (for example, alignment) in the Image Properties dialog 
box.

5.

Tip: To quickly insert an image: Drag and drop it onto your page.
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Tip: To insert a line break after all images in a paragraph, choose Break Below Images from the Insert menu.

[Return to beginning of section]

Editing Image Properties
Once you've inserted an image into your page, you can edit its properties and customize the layout in your page, such
as the height, width, spacing, and text alignment. If you are not currently viewing the Image Properties dialog box, follow
these steps:

Double-click the image, or select it and click the Image button  on the toolbar to display the Image Properties
dialog box.

1.

Click the Location tab to edit these properties:
Image Location: Type the filename and location of the image file. Click Choose File to search for an
image file on your hard drive or network.
URL is relative to page location: If checked, Composer converts the URL to be relative to the
page's location. This is especially useful if you plan to publish your pages on a web server so that others
can view them. Using relative URLs allows you to keep all your linked files in the same place relative to
each other, regardless of their location on your hard disk or a web server.

Unchecking this box causes Composer to convert the URL to a full (absolute) URL. You typically use
absolute URLs when linking to images on other web servers (not stored locally on your hard disk).

If you have never saved or published the page, you must first save the page in order to enable this
checkbox. (This checkbox is not available if you open the Image Properties dialog box in a message
compose window.)

Attach this image to the message: If checked, the image is attached to the message you are
sending. If unchecked, a link to the image location is inserted instead. (This checkbox is only available if
you open the Image Properties dialog box in a message compose window.)
Alternate Text: Enter text that will display in place of the original image; for example, a caption or a
brief description of the image. It's a good practice to specify alternate text for readers who use text-only
web browsers or who have image loading turned off.
Don't use alternate text: Choose this option if the image does not require alternate text or if you
don't want to include it.

2.

Click the Dimensions tab to edit these properties:
Actual Size: Select this option to undo any changes you've made to the dimensions and return the
image to its original size.
Custom Size: Select this option and specify the new height and width, in pixels or as a percentage.
This setting doesn't affect the original image file, just the image inserted in your page.
Constrain: If you change the image size, it's a good idea to select this in order to maintain the image's
aspect ratio (so that it doesn't appear distorted). If you choose this option, then you only need to change
the height or width, but not both.

3.

Click the Appearance Tab to edit these properties:
Spacing: Specify the amount of space surrounding the image; between the image and adjoining text.
You can also put a solid black border around the image and specify its width in pixels. Specify zero for no
border.
Align Text to Image: If you've placed your image next to any text, select an alignment icon to
indicate how you want text positioned relative to the image.
Image Map: Click Remove to remove any image map settings.

4.

Click the Link tab to edit these properties:
Enter a web page location: If you want to define a link for this image, enter the URL of a remote or
local page, or select a named anchor or heading from the drop-down list. Click Choose File to search for a
file on your hard drive or network.
URL is relative to page location: If checked, Composer converts the URL to be relative to the
page's location. This is especially useful if you plan to publish your pages to a web server so that others
can view them. Using relative URLs allows you to keep all your linked files in the same place relative to
each other, regardless of their location on your hard disk or a web server.

5.
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Unchecking this box causes Composer to convert the URL to a full (absolute) URL. You typically use
absolute URLs when linking to files on other web servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to enable this checkbox. (This
checkbox is not available if you open the Image Properties dialog box in a message compose window.)

Show border around linked image: If checked, displays the link highlight color around the image.
To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced Property 
Editor.

6.

Click OK to confirm your changes.7.

[Return to beginning of section]

Setting Page Properties

In this section:

Setting Page Properties and Meta Tags
Setting Page Colors and Backgrounds

Setting Page Properties and Meta Tags
Use the Page Properties dialog box to enter properties such as the title, author, and description of the document you're
currently working on. This information is useful if you plan to use the page on a website, since search engines use this
type of information to index your page. You can view this information from the browser window by opening the View menu
and choosing Page Info.

Open the Format menu and choose Page Title and Properties.1.
Edit any of the following properties:

Title: Type the text you want to appear as the window title when someone views the page through a
browser. This is how most web search tools locate web pages, so choose a title that conveys what your
page is about.
Author: Type the name of the person who created the document. This information is helpful to readers
who locate the document by using a web search tool to search on name.

Tip: If you enter the Author name in Composer's preferences, then you won't have to enter it each time
you create a new page.

Description: Enter a brief description of the document's contents.

2.

[Return to beginning of section]

Setting Page Colors and Backgrounds
You can change the background color or specify a background image for the page you're currently working on. These
choices affect the way text and links in your page appear to people viewing the page through a browser.

To set the colors and background for the current page, begin from the Composer window:

Open the Format menu and choose Page Colors and Background.1.
Edit any of the following properties:

Reader's default colors: Select this if you want your page to use the color settings from the viewer's
browser for text and links.
Use custom colors: Select this if you want to specify the colors of text and links. For each element,
select a color from the Color selection dialog. Sample output for each type of link appears in the pane on

2.
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the right.
Background image: Select this if you want the background of your page to be an image. Type the
name of the image file or click Choose File to locate the image file on your hard drive or network.

Note: Background images are tiled and override background color selections.

URL is relative to page location: If checked, Composer converts the URL to be relative to the
page's location. This is especially useful if you plan to publish your pages on a web server so that others
can view them.

Using relative URLs allows you to keep all your linked files in the same place relative to each other,
regardless of their location on your hard disk or a web server.

Deselecting this option causes Composer to convert the URL to a full (absolute) URL. You typically use
absolute URLs when linking to images on other web servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to enable this checkbox.

Note: To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced Property Editor.

You can also set the default page background and colors for every new page you create in Composer.

[Return to beginning of section]

Creating Links in Composer

In this section:

Creating Links Within the Same Page
Creating Links to Other Pages
Using Images as Links
Removing or Discontinuing Links

Creating Links Within the Same Page
To create a link within the same page, for example a link that the reader can use to jump from one section to another, you
must create an anchor (target location), and then create a link that points to the anchor. Anchors are also called named 
anchors. To create an anchor, follow these steps:

Click to place the insertion point at the beginning of a line where you want to create an anchor, or select some
text.

1.

Open the Insert menu and choose Named Anchor. You see the Named Anchor Properties dialog box.2.
Type a unique name for the anchor in the Anchor Name field (up to 30 characters). If you include spaces, they will
be converted to underscores ( _ ). If you selected some text in step 1, this box already contains a name.

3.

Click OK. An anchor icon appears in your document to mark the anchor's location: 4.

To create the link on which readers can click to jump to the object:

Select the text or image that you want to link to the anchor.1.
Click the Link button or open the Insert menu and choose Link. You see the Link Properties dialog box.

If you're creating a link to an HTML file on your computer, click Choose File to locate it.
If you're creating a link to a named anchor (target), select it from the list of the anchors currently available
in the page.
If you're creating a link to a level heading (for example, Heading 1 - Heading 6), select it from the list of
headings currently available in the page.

2.

Click OK.3.
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Note: To test the link you just created, open the File menu and choose Browse Page, then click the link.

Tip: If you did not first create named anchors, you can use the Link dialog box to create links to headings that already
occur in the page.

[Return to beginning of section]

Creating Links to Other Pages
You can create links from your page to local pages on your own computer or on your workplace's network, or to remote
pages on the Internet.

Tip: It's best to first save or publish your page before you create links to other pages. This allows Composer to
automatically use relative references for links once you create them.

To create a link to another page:

Click to place the insertion point where you want to create a link, or select the text or image that you want to link
to the anchor.

1.

Click the Link button. You see the Link Properties dialog box.2.
Define your link:

Link text: If you've already selected an image file or text before clicking the Link button, the selected
text or file will be entered here. Otherwise, you must enter the text that you want to use as the link.
Link Location: Type the local path and filename or remote URL of the page you want to link to. If you're
not sure of the path and filename for a local file, click Choose File to look for it on your hard disk or
network. For remote URLs, you can copy the URL from the browser location field. Alternatively, you can
select a named anchor or a heading in the current page that you want to link to.
URL is relative to page location: If checked, Composer converts the URL to be relative to the
page's location. This is especially useful if you plan to publish your pages to a web server so that others
can view them. Using relative URLs allows you to keep all your linked files in the same place relative to
each other, regardless of their location on your hard disk or a web server.

Deselecting this option causes Composer to convert the URL to a full (absolute) URL. You typically use
absolute URLs when linking to pages on other web servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to enable this checkbox. (This
checkbox is not available if you open the Link Properties dialog box in a message compose window.)

Attach the source of this link to the message: If checked, the source of the specified link is
added as an attachment to the message you are sending. If unchecked, just a link to the location is
inserted instead. (This checkbox is only available if you open the Link Properties dialog box in a message
compose window.)

3.

To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced Property 
Editor.

4.

Click OK.5.
To test the link you just created, click the Browse button and then click the link to make sure it works as
expected.

6.

Tip: You can copy a link quickly by clicking and dragging the link from another window and then dropping it onto your
page. For example, you can click and drag a link from a web page, bookmark, or Mail window and drop it onto your page.
You can also right-click or, if you have a one-button mouse, Ctrl-click a link on a web page and choose Copy Link
Location from the menu. Then you can paste the link location into the Link Location field in the Link Properties dialog
box.

[Return to beginning of section]

Using Images as Links
You can make images, such as JPEG, GIF, or PNG files, behave like links in your pages. When the reader clicks a
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linked image, the browser window displays the page that the image is linked to.

To make an image behaving like a link:

Select an image on your page.1.

Click the Link button  on the toolbar, or open the Insert menu and choose Link.2.
Use the Link Properties dialog box to link the image to a named anchor or heading within the page, or to a
separate local or remote page.

3.

Tip: Drag and drop a linked image from the Navigator window into a Composer window to copy both the image and the
link.

Note: To remove the blue border on images used as links, open the Link Properties dialog box, click the Link tab, and
uncheck “Show border around linked image”.

[Return to beginning of section]

Removing or Discontinuing Links
To remove a link:

Select the linked text (normally blue and underlined) or image.1.
Open the Format menu and choose Remove Links.2.

To discontinue a link, so that text you type after the link is not included as part of the link:

Click to place the insertion point where you want the link to end.1.
Open the Format menu and choose Discontinue Link.2.

[Return to beginning of section]

Publishing Your Pages on the Web
If your pages exist only on your local hard disk, you can browse your pages, but no one else can. Composer lets you
publish your pages to a remote computer called a web server.

When you publish your pages to a web server, Composer copies (uploads) your pages to a computer that lets others
browse your pages. Most ISPs provide space on their web servers for web page publishing. To find a web server where
you can publish your pages, ask your ISP, help desk, or system administrator.

In this section:

Publishing a Document
Updating a Published Document
Changing the Filename or Publishing Location
Creating a New Publishing Site
Choosing the Default Publishing Site
Deleting a Publishing Site
Solving Common Publishing Problems
Publishing Settings

Publishing a Document
Tip: It's best to first save or publish your page before you insert links or images into it. This allows Composer to
automatically use relative references for links and images once you insert them.
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To publish a document:

Open the HTML document that you want to publish, or create a new Composer document.1.
When you're ready to publish the document remotely, click the Publish button.
If you have published this document before, Composer remembers the document's publishing settings and starts
publishing the document. While publishing is in progress, Composer displays a publishing status dialog box.

If you have never published this document before, Composer displays the Settings tab in the Publish
Page dialog box so you can enter information about the document's remote publishing location. See
Publish Page - Settings for more information. When you're done entering information, click Publish.
If you have never saved the document, Composer displays the Publish tab in the Publish Page dialog
box, so you can enter the document's filename. See Publish Page - Publish for more information. After
entering the filename, click Publish.

2.

To browse your published page, click the Browse button. Test the page's links and make sure there are no
missing images.

3.

Continue editing the page as necessary. When you're ready to update the remote page with your changes, click
the Publish button.

4.

When you publish a document for the first time, Composer changes the document's file:/// URL to an http://
URL to indicate that you are now editing the published document. If you want to save the document locally (on your
computer's hard disk), click the Save button. You'll be prompted to choose a filename and location on your hard disk for
the document.

[Return to beginning of section]

Tips for Avoiding Broken Links or Missing Images

Make sure your Composer filenames end with the .html or .htm file extension. Make sure your image filenames
end with the .JPG, .GIF, or .PNG file extension. Don't use spaces or other special symbols in your filenames.
Keep your filenames short and only use lowercase or uppercase letters and numbers.
If your images appear as broken links when you browse a document on the web server, you may have forgotten
to include the images when you published. Open the File menu, and choose Publish As to display the Publish
Page dialog box. In the Publish tab, make sure you check “Include images and other files” and then click Publish.

For more troubleshooting tips, see Solving Common Publishing Problems.

[Return to beginning of section]

Updating a Published Document
To update a published document:

In a Composer window, open the File menu, and choose Recent Pages, then select the document from the list.
Alternatively, browse to the location of the document you want to update by entering the document's HTTP
address (the document's web address) in the Navigator browser's Location field.

1.

Edit the document as necessary.2.
When you're ready to update the remote page with your changes, click Publish in Composer's toolbar.3.

Tip: To delete a page or image you've published on a web server, you must use an FTP (File Transfer Protocol) program. 
You also must use an FTP program if you want to create subdirectories or to rename files on the web server. Ask your
service provider if they recommend a particular FTP program. You can usually find information on FTP programs in the
Help or Support sections of your service provider's website. FTP programs are also available from shareware sites such
as ZDNet Downloads.

[Return to beginning of section]

Changing the Filename or Publishing Location
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To change a document's filename or publishing location:

In a Composer window, open the File menu, and choose Recent Pages, then select the document from the list.
Alternatively, browse to the location of the document you want to update by entering the document's HTTP
address (the document's web address) in the Navigator browser's Location field.

1.

Edit the document as necessary.2.
Open Composer's File menu and choose Publish As. Composer displays the Publish tab in the Publish Page
dialog box.

3.

Enter a different page title, if necessary.4.
Enter a different filename for the page, if necessary.5.
From the Site Name list, choose the publishing location you want to use. To set up a new publishing location,
click New Site. See Publish Page - Settings for more information.

6.

Click Publish to save the document to the new location.7.

[Return to beginning of section]

Creating a New Publishing Site
If you plan to publish documents to more than one remote location, you can set up Composer to save the publishing
information for each remote site you use, so that you don't have to enter it each time you want to publish.

To create a new publishing site, begin from a Composer window:

Open the Edit menu and choose Publishing Site Settings. Composer displays the Publish Settings dialog box.1.
Click New Site.2.
For “Site Name”, enter the nickname by which you want to refer to this publishing site.

For example, if you will use the new site to publish documents related to the “Meteor” project, you might want to 
use the site name “Meteor”. Site names remind you about the types of documents you publish at each site.

3.

For “Publishing address”, enter the complete URL provided to you by your ISP, system administrator, or web
hosting service. This URL must begin with either ftp:// or http://.

The publishing address specifies the location where documents are published (uploaded) at this site. If you are
not sure what to enter, ask your ISP or system administrator.

4.

For “HTTP address of your home page”, enter the complete URL that you would enter in the Navigator browser to
view pages at this site. Do not include a filename or subdirectory as part of the URL.

This URL must always begin with http://. In some cases, this URL is the same as the publishing address. If
you are not sure what to enter, ask your ISP or system administrator, or else leave it blank.

5.

For “user name”, enter the user name you use to log in to your ISP or web hosting service.6.
For “password”, enter the password for your user name.7.
Select “Save Password” to save your password securely using Password Manager so that you don't have to
enter it each time you publish pages at this site.

8.

Click OK.9.

[Return to beginning of section]

Choosing the Default Publishing Site
If you have set up more than one publishing site, but you typically use only one site for most of your publishing needs,
you can designate the site you use most often as the default publishing site. Composer will use the default publishing
site for all documents that you publish, unless you specifically choose an alternate site.

Regardless of how many sites you've set up, you can always publish a document to a different site by choosing Publish
As from Composer's File menu. See Changing the Filename or Publishing Location for more information.
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To choose the default publishing site, begin from a Composer window:

Open the Edit menu, and choose Publishing Site Settings. Composer displays the Publish Settings dialog box.1.
Select a publishing site from the list.
If you only have one publishing site set up, Composer uses that one as the default site.

2.

Click Set as Default.3.
Click OK to confirm your changes.4.

[Return to beginning of section]

Deleting a Publishing Site
Deleting a publishing site removes the site's settings from Composer. If you later wish to publish to the site, you must
re-enter the site's settings.

To delete a publishing site's settings, begin from a Composer window:

Open the Edit menu, and choose Publishing Site Settings. Composer displays the Publish Settings dialog box.1.
Select a publishing site from the list.2.
Click Remove Site.
Composer only removes the site's settings; the remote site itself is not affected.

3.

Click OK to confirm your changes.4.

[Return to beginning of section]

Solving Common Publishing Problems
If one or more of your files fail to publish, the Publishing Status dialog box displays an error message that can help you
determine what went wrong and how to fix it. Click the Troubleshooting button in the Publishing Status dialog box to get
help on solving your publishing problem.

If you are still unable to publish a file, save the file to your hard disk by opening Composer's File menu, and choosing
Save. You can then open the file at a later time to try to publish it. To quickly locate the file later, open Composer's File
menu, and choose Recent Pages.

In this section:

Verifying Your Publishing Settings
Checking Your Filenames
Fixing Publishing Errors

Verifying Your Publishing Settings

To verify your publishing settings:

Close the Publishing Status dialog box, if it is open.1.
Open the Edit menu and choose Publishing Site Settings.2.
In the Publish Settings dialog box, confirm that the site settings are correct for the site you are trying to publish
to. If you're not sure, check with your ISP or web hosting service.

Verify that you correctly entered the publishing settings: You may have accidentally 
mis-typed one of the settings.
Verify that you entered the correct publishing address: Web hosting services or ISPs may 
refer to the publishing address as the “server name”, the “hostname”, or the “server/host”. They often 

3.
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specify the publishing location as ftp.myisp.com/username, where username is your user
name.

For the publishing address to be correct, you must precede the publishing location with either ftp:// or 
http://. For example, the correct publishing address for the above-mentioned site would be
ftp://ftp.myisp.com/username.

Checking Your Filenames

Examine the names of any files that failed to publish. Make sure that the filenames:

Use only numbers or lowercase or uppercase letters. While it's acceptable to create filenames that use
uppercase letters, you can avoid potential errors in later locating the published file if you only use lowercase
letters in your filenames.
When you publish files to a web server, filenames become case-sensitive on the web server. It may be harder for
you to remember files names that use only uppercase letters or that use a mix of uppercase and lowercase
letters.

For example, when you try to locate a published file by typing the filename's web address into Navigator's
Location field, you must enter the filename exactly as you created it, using the same combination of uppercase
and lowercase letters.

Don't use punctuation characters or spaces. Underscores ( _ ) or hyphens ( - ) are OK.
End with .html or .htm (for Composer filenames).
Use less than 32 characters.

Fixing Publishing Errors

If one or more of your files fails to publish, look at the messages Composer displays in the Publishing Status area of the
Publishing dialog box. You can use these error messages to help determine what went wrong and what to do to fix the
problem.

Error Messages:

Filename not found.

X of Y files failed to publish.

The subdirectory directory name
doesn't exist on this site or the 
filename filename is already in use
by another subdirectory.

The filename filename is already in
use by another subdirectory.

The server is not available. Check 
your connection and try again later.

You do not have permission to publish 
to this location.

You are currently offline. Click the 
icon near the lower-right corner of
any window to go online.
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There is not enough disk space 
available to save the file filename.

The filename or subdirectory name is 
too long.

Error Message:

Filename not found.

or

X of Y files failed to publish.

Error Description: One or more image files or CSS files failed to publish because Composer could not find them.
Some typical reasons might be:

The file location you typed is incorrect.
The file's location on the web is not accessible.
The file's location was changed or the file was deleted or moved to another location.

Possible Solutions:

Look for broken images in the page you are trying to publish. Broken images will appear with this icon  in the
page. To correct the image's address, double-click the broken image to display the Image Properties dialog box
so you can enter the correct address.
Remove the broken image from the page by selecting it (click once on the image), and then pressing Backspace
or Delete on your keyboard.
If the image is unavailable because the server where the image resides is inaccessible, try publishing the page at
a later time.
If the missing file is a CSS file, you must first verify the correct location of the CSS file. To fix the file's address in
Composer, click the HTML Source tab and edit the file's location in the HTML source code. You should only edit
the HTML source if you are familiar with HTML tags.

Error Message:

The subdirectory directory name
doesn't exist on this site or the
filename filename is already in use 
by another subdirectory

or

The filename filename is already in 
use by another subdirectory

Error Description: You specified the name of a remote subdirectory that does not exist at the publishing site.
Composer can only publish to a remote subdirectory that already exists at the publishing location. Or, you specified a
filename that is identical to the name of an existing subdirectory at the publishing site.

For example, in the Publish Page dialog box, under the Publish tab:

for “Site subdirectory for this page”, you may have typed the name of a subdirectory that does not exist at the
publishing location.
you checked “Include images and other files”, and then you typed the name of a subdirectory that does not exist
at the publishing location.
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one of the files you are attempting to publish has the same name as a subdirectory at the publishing site.

Possible Solutions:

Use a separate FTP program if you want to create, rename, or delete subdirectories at the publishing site. Ask
your service provider if they recommend a particular FTP program. You can usually find information on FTP
programs in the Help or Support sections of your service provider's website. FTP programs are also available
from shareware sites such as ZDNet Downloads.
Don't use subdirectory names that end with “.html” or “.htm”. Only your Composer filenames should end with 
“.html” or “.htm”.
Subdirectory names are case-sensitive, so be sure to enter a subdirectory name exactly as it appears at the
publishing location.

Error Message:

The server is not available. Check 
your connection and try again later.

Error Description: This error can have many causes. For example:

Your publishing site settings may not be correct.
Your Internet connection may have been lost.
Your modem or other equipment that you use to connect to the Internet might not be functioning correctly.
The web server that you are trying to publish to might be unavailable due to a technical problem or to an unknown
circumstance.
Your ISP or web hosting service may be experiencing technical problems.

Possible Solutions:

Verify that your publishing settings are correct and that you entered them correctly. See Verifying Your 
Publishing Settings for more information.
Make sure your Internet connection is working by attempting to view a web page using the Navigator browser. For
example, confirm that you can successfully view the page http://www.mozilla.org.
If your Internet connection is not working, verify that all hardware, telephone connections, modems, and network
connections are functioning properly.
Use the Navigator browser to try to view a page at the website you are attempting to publish to. If you can
successfully view other websites but cannot view a page at the publishing site, your ISP or web hosting service
may be experiencing technical problems.
Try publishing again later. Your ISP, web hosting service, or the web server may be experiencing temporary
technical difficulties.

Error Message:

You do not have permission to publish 
to this location.

Error Description: You are attempting to publish to a location that you are not authorized to use. You can only
publish to sites where you have been granted access by your ISP or web hosting service.

Possible Solutions:

Verify that you entered the correct user name and password in the Publishing Site Settings dialog box, or in the
Publish tab of the Publish dialog box.
Contact your ISP to find out where you can publish your pages at their site.
Find a web hosting service that you can use to publish your pages. In the Navigator browser, search for “web 
hosting”.
Use Netscape My Webpage http://mywebpage.netscape.com/  to host your web pages, up to 20
megabytes for free.
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Error Message:

You are currently offline. Click the 
icon near the lower-right corner of
any window to go online.

Error Description: You are attempting to publish, but your SeaMonkey Internet connection is currently in the “offline”
state. Your Internet connection must be in the “online” state (connected to the Internet) in order to publish your pages.

Verify that your Internet connection is currently offline by looking at the online/offline icon in the lower right corner of any

SeaMonkey window. If you are currently offline, the icon appears as .

Possible Solutions:

Click the online/offline icon to go online. In the online state, the icon should look like this: .
Make sure your Internet connection is working by attempting to view a web page using the Navigator browser. For
example, confirm that you can successfully view the page http://www.mozilla.org.

Error Message:

There is not enough disk space 
available to save the file filename.

Error Description: The remote web server's hard disk is full, or you may have exceeded the amount of disk space
allocated to you by your ISP or web hosting service.

Possible Solutions:

Use a separate FTP program to delete unnecessary files at your publishing site. Ask your service provider if they
recommend a particular FTP program. You can usually find information on FTP programs in the Help or Support
sections of your service provider's website. FTP programs are also available from shareware sites such as
ZDNet Downloads.
Find out from your ISP or web hosting service about increasing your disk space allocation, or switch to a different
service that can satisfy your needs.
If the web server is located at your company or school, contact the network administrator to find out if you can
publish to a different location that has more disk space, or if you can request that additional disk space be
allocated to your current publishing location.

Error Message:

The filename or subdirectory name is 
too long.

Error Description: The number of characters in the filename or the subdirectory name is not supported by the web
server computer that you are trying to publish to.

Possible Solutions:

Limit the length of your filenames and subdirectory names to less than 32 characters. Some operating systems
do not support names longer than 32 characters.

[Return to beginning of section]

Publishing Settings
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This section describes Composer's publishing settings. For information on Composer's general and new page settings,
see Composer Preferences.

In this section:

Publish Page - Publish
Publish Page - Settings
Publish Settings

Publish Page - Publish

The Publish Page - Publish tab lets you specify where you want to publish a document. These settings apply to the
current document.

If you are not already viewing the Publish Page - Publish tab, follow these steps:

Open the File menu and choose Publish As. The Publish Page dialog box appears.1.
Click the Publish tab.2.

Site Name: Lists all the publishing sites you've created, so you can choose the site that you want to publish to.
To create a new site, click New Site.
Page Title: Specifies the document's page title as it appears in the browser window's title bar when you view
the page in the browser. The document's page title also appears in your list of bookmarks if you bookmark the
page.
Filename: Specifies the document's filename. Make sure you include the .html or .htm extension in the
filename.

Warning: If a file on the remote site you're publishing to has the same filename as one you're uploading, the
newly uploaded file will replace the existing one. You will not be asked to confirm the action.

Site subdirectory for this page: If you leave this blank, Composer publishes the page to the main (root)
publishing directory at this site. If you want to publish the page to a remote subdirectory that resides underneath
the main publishing directory at this site, enter the name of the subdirectory or choose it from the list. Composer
keeps track of the locations you type here, so you can select from a list of remote locations you've previously
used. Keep in mind that subdirectory names are case-sensitive.

Note: The site subdirectory you choose must already exist at the remote server.

Include images and other files: If checked, Composer publishes any images and other files referenced by
this page. You can choose to publish these files to the same location as the page, or else you can choose to
publish these files into a remote subdirectory that exists underneath the main publishing directory.

Tip: To create remote subdirectories or delete published pages or images, you must use an FTP (File Transfer Protocol)
program. Ask your service provider if they recommend a particular FTP program. You can usually find information on FTP
programs in the Help or Support sections of your service provider's website. FTP programs are also available from
shareware sites such as ZDNet Downloads.

[Return to beginning of section]

Publish Page - Settings

The Publish Page - Settings tab lets you specify your login information for the remote publishing site, as well as the
publishing settings for the remote site. These settings apply to the current document and any other files you publish to
this location.

If you are not already viewing the Publish Page - Settings tab, follow these steps:
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Open the File menu and choose Publish As. The Publish Page dialog box appears.1.
Click the Settings tab.2.

Site Name: Specifies the nickname you want to use for this publishing site. Enter a short name that will help
you identify this publishing site.
Publishing address: Specifies the complete URL provided to you by your ISP or system administrator. This
URL should begin with either ftp:// or http://. This name is often referred to as the “host name” or the 
“host server name”.

The publishing address specifies the location where documents are published (uploaded) at this site. If you are
not sure what to enter, ask your ISP or system administrator.

HTTP address of your home page: Specifies the complete address of your publishing home directory.
This is the web address of the home page at your website. Do not include a filename or subdirectory as part of the
URL.

This URL must always begin with http://. In some cases, this URL is the same as the publishing address. If
you are not sure what to enter, ask your ISP or system administrator, or else leave it blank.

User name: Specifies the user name you use to log into your ISP or network.
Password: Specifies the password for your user name.
Save Password: Select this to encrypt and save your password securely using Password Manager so that
you don't have to enter it each time you publish pages at this site.

[Return to beginning of section]

Publish Settings

The Publish Settings dialog box lets you create, edit, and delete publishing site settings, and also lets you set the
default publishing site.

If you are not already viewing the Publish Settings dialog box, follow these steps:

Open the Edit menu and choose Publishing Site Settings. Composer displays the Publish Settings dialog box.1.

New Site: Lets you specify settings for a new publishing site. Composer adds the name of the new publishing
site to the list of available publishing sites.
Set as Default: Sets the selected publishing site as the default publishing site. Typically, the default
publishing site is the remote location that you most often use for publishing documents. All documents you
create or edit will be published to the default publishing site, unless you specifically choose an alternate site in
the Publish Page dialog box.

To publish a document to a different remote location, open the File menu and choose Publish As to choose a
different publishing destination.

Remove Site: Removes the selected site and its settings from Composer.
Site Name: Specifies the name by which you want to refer to this publishing site.
Publishing address: Specifies the complete URL provided to you by your ISP or system administrator. This
URL should begin with either ftp:// or http://.

The publishing address specifies the location where documents are published (uploaded) at this site. If you are
not sure what to enter, ask your ISP or system administrator.

HTTP address of your homepage: Specifies the HTTP address of your publishing home directory. Do not
include a filename or subdirectory as part of the URL.

This URL must always begin with http://. In some cases, this URL is the same as the publishing address. If
you are not sure what to enter, ask your ISP or system administrator, or else leave it blank.

User name: Specifies the user name you use to log in to your ISP or network.
Password: Specifies the password for your user name.
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Save Password: Select this to save your password securely using Password Manager so you don't have to
enter it each time you publish pages at this site.

[Return to beginning of section]

Composer Preferences
This section describes the settings in the Composer preferences panel. If you are not currently viewing the panel, follow
these steps:

Open the SeaMonkey menu and choose Preferences.1.
Double-click the Composer category to expand the list.2.

For information on Composer's publishing settings, see Publishing Settings.

In this section:

Composer
New Page Settings

Composer Preferences - Composer
Composer preferences allow you to specify settings for saving files and for table editing. These settings apply to every
document you create.

If you are not already viewing the Composer preferences, follow these steps:

Open the SeaMonkey menu and choose Preferences.1.
Click the Composer category.2.

Maximum number of pages listed: Specify the maximum number of pages that are listed under Recent
Pages in the File menu.
Preserve original source formatting: Select this if you want to preserve the original white space (extra
lines, tabs, etc.) in the HTML source code. Deselect this if you prefer Composer to indent and add linebreaks to
the code in order to make it more readable. This preference does not affect how your pages appear in a browser
window.
Save images and other associated files when saving pages: If checked, all images, JavaScript 
(JS), Cascading Style Sheet (CSS), and other associated files are saved in the same location as the document
when the document is saved for the first time or when the document is saved to a new location. If unchecked,
only the HTML file is saved.

For example, when editing a remote page, this setting ensures that all related files associated with the remote
page will be saved locally when you save the page to your hard disk.

Always show Publish dialog when publishing pages: If checked, Composer always displays the
Publish Page dialog box when you click the Publish button or choose Publish from the File menu. If not checked,
Composer only displays the Publish Page dialog box if it needs more information in order to publish the page.
Maintain table layout when inserting or deleting cells: Select this if you want Composer to always
preserve the table's layout (that is, keep it in a rectangular shape) by adding cells where needed. If you deselect
this option, when you delete one or more cells, Composer removes the cell border as well, which can result in a
table with empty spaces, or an outline that appears irregular due to an uneven number of cells.
Use CSS styles instead of HTML elements and attributes: Enables the use of Cascading Style
Sheet (CSS) formatting in your Composer documents. With this preference enabled, Composer generates HTML
4.01 formatting with CSS inline styles for elements.

If this preference is not enabled, Composer generates HTML 4.01 formatting, but does not use CSS styles.
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Compared to HTML, HTML with CSS formatting is more portable, more maintainable, and more compatible when
viewed with different browsers. If you enable this preference and then edit a document created without CSS,
Composer replaces the edited elements with CSS styles.

If you enable CSS styles, you can choose a text highlight color for selected text using the text highlight color
button on the Format toolbar. You can also choose a color background for any element on the page. (These
features are not available if this preference is not enabled.)

Return in a paragraph always creates a new paragraph: If selected, a new paragraph will be added
everytime you press the Return key inside a paragraph. If deselected, a linebreak will be added when you press
the Return key.

[Return to beginning of section]

Composer Preferences - New Page Settings
New page preferences allow you to specify settings for colors and background images that apply to every document you
create.

If you are not already viewing the New Page Settings, follow these steps:

Open the SeaMonkey menu and choose Preferences.1.
Double-click the Composer category and click New Page Settings.2.

Author: Enter your name. This will add your name to the HTML source code for each new page you create.
Reader's default colors: Select this if you always want your pages to use the color settings from the
viewer's browser for text and link elements.
Use custom colors: Select this if you always want to specify the colors that are applied to text and link
elements. Then for each element, select a color by clicking the color button next to each element.
Background image: Type the location and name of an image file, or click Choose File to locate the image file
on your hard disk or network.

Note: Background images are tiled and override background color.

To change the author name for an individual page: Open the Format menu and choose Page Title and Properties.

To change the page colors and background image for an individual page: Open the Format menu and choose Page
Colors and Background.

[Return to beginning of section]
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