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GEOMETER’S SKETCHPAD 4.0 
 
This program is the mathematician’s toolbox. 
 
�  Selection Arrow tools: used to select and drag objects in your sketch.  

Variations are drag-translate, drag-rotate, drag-dilate. 
 
Point tool: used to construct points. 

Compass tool: used to construct circles. 
Straightedge tool: used to construct straight objects.  Variations are 
segment, ray, and line. 
 
Text tool: used to create and edit text and labels. 
 
Custom tools icon: used to define, use, and manage custom tools. 
 

 

The menu bar contains the following choices: 
 
The File menu has the usual Macintosh or Window choices of 
Open, Save, Print, etc.  Print Preview is very useful because it 
lets you scale your drawing to fit the printed page. 
 
The Edit menu has the usual Cut, Copy, Paste and Clear 
options.  The Undo allows you to undo continuously, back to 
your very first step — very useful.  This menu also contains 
Action Buttons, which are used to create buttons for 
movement, animation, hide/show, presentation, link and 
scroll.  This menu also contains items called Select, Select 
Parents and Select Children.  (See below) 
 
Select: If you select the Arrow tool and then the choice under 

the Edit menu is Select All.  If the Point tool is selected, then the choice under the Edit menu is 
Select All Points.  If the Compass tool is selected, then the choice under the Edit menu is Select 
All Circles.  Likewise, if the Straightedge tool is selected, then the choice under the Edit menu is 
Select All Segments (or Rays or Lines). 
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Parents and Children:  When 
you select the necessary objects 
and then construct something, 
the construction is the child and 
the original objects are the 
parents.  You can move a 
parent, or change its size, and 
thereby modify the child.  You 
may not move a child in such a 
way that it changes the parent.  
(Moving a child will slide the 
entire figure on the page.)  
When you point at an object, the 
pointer turns sideways and the 
object is identified in the lower 
right corner of the screen. 
 
The Preferences item is very 

important.  Here you can set the units 
and precision for measurements and 
computations. 
 
You can choose colors. 
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You can make choices about labeling. 
 
 
 
 
 
 
 

The Display menu contains several useful tools.  The 
top part contains choices to change line thickness, 
color, and text size and font.  The next two sections 
deal with hiding and showing objects and labels.  This 
allows you to hide constructions or parts of 
constructions.  The next choice allows you to trace the 
path of an object (locus).  The Animate choice lets 
you move an object.  If a point is constructed on an 
object, then it will move it along this path (segment or 
circle).  If the object is free, then it will move it 
randomly around the screen.  This animation differs 
from the animation under the Action Buttons on the 
Edit menu, which creates a button you can turn off 
and on. 
 
 
 
 
Constructi
on Tools:   
Under the 
Construct 

menu, you have the usual constructions from which to 
choose.  Unlike the other geometry programs, you 
must first select the required points, lines, etc. before 
you choose the construction.  For example, if you 
select two points and then go to the construction 
menu, you will see Segment, Ray, Line and Circle By 
Center+Point darkened.  These are the constructions 
possible with two points.  (Since the circle choice lists 
center+point, the first point will be the center and the 
second a point on the circle.) 
 
If you select an object, such as a circle or line, then 
you can choose Point On Object.  This gives you a 
point that you can then drag to any location on the 
object by the point-click-and-drag method.  This point 
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cannot be moved off the original object, unlike a point created by the Freehand tool.  You can, 
however, split the point from the object using the choice under the Edit menu. 
 
To construct an Arc On Circle, you first select the center, the first point on the arc, then the 
second point going counter-clockwise.  This enables you to construct both major and minor arcs.  
You can also select 3 points and construct an arc through those points.  Once an arc is selected, 
you can construct the sector or segment interior. 
 
To construct a polygon, select the vertices in order, then choose segment under the Construct 
menu.  To measure the area of a circle or polygon, you must first construct its interior.  To 
construct the interior of a circle, simply select the circle.  To construct the interior of a polygon, 
select the vertices in order. 
 
If you select something you don’t want, you can unselect it by clicking on it again.  To unselect 
everything that is currently selected, simply point at a blank area of the screen and click or press 
escape.  To select several objects, just click on them, but remember for certain constructions, 
order matters. 

 
Transformation Tools:   The Transform menu has choices 
to Translate, Rotate, Dilate, and Reflect.  For the first three 
transformations, before you click the Transform button, you 
will see a sketch of what the result will look like. 
 
You can translate by a vector in polar notation (distance & 
angle), rectangular notation (∆x, ∆y), or a marked vector 
(from one point to another). 
 
In order to rotate, you must first designate a center point, 
then you can rotate by a fixed angle (enter degrees) or 
marked angle (designated by 3 points). 
 
To dilate, you must designate a center point, then enter a 
fixed ratio or a marked ratio (designate 2 segments). 

 
To reflect, you must first select a straight object for the 
mirror. 
Measurement Tools:   You can select objects, then go to the 
Measure menu to get the measurement.  You can select two 
points to get Distance or a segment to get Length.  You need 
three points for the measure of an Angle.  Angles are 
measured counter-clockwise.  To measure the circumference 
of a circle, select the circle.  To measure the Perimeter or 
Area of an object, you must first construct the interior (see 
Construction tools). 
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If you select the circle and 2 points on it, you can measure the minor arc with those end points, 
with either the arcangle or arclength.  If you select the arc itself, you can get those measures for 
either the major or minor arc. 
 
Unfortunately, when selecting a segment, circle, or arc, the program calls them by their names, 
such as j (for segment), c1 (for circle), or a2 (for arc).  You can change these names by using the 
Text tool. 
 
You can measure the Slope of a line, line segment, or ray.  You can also obtain the Coordinates 
of a point or the Equation of a line or circle.  These selections will automatically put coordinate 
axes on the screen using the unit set under preferences.  Equation will not give the equation of a 
line segment, so a line must be constructed collinear with the segment. 
 
If you change things that have been measured, the measurements will also change.  This is the 
dynamic part of this program. 
 
Notice that the measurements are right on the graphics screen.  You can select them and move 
them by the point-click-and-drag maneuver.  You can do calculations with several measurements 
by selecting them (multiple selections), then choose Calculate under the Measure menu.  You 
will see a calculator with rectangle labeled Value.  This rectangle is a pull-down menu 
containing the measurements you selected, plus π and e.  If you have selected the coordinates of 
a point before going to Calculate, you can return just the x or y coordinate.  You calculate by 
selecting values and operations.  You can also enter numbers by clicking on them, just like 
buttons on a calculator.  There is also a Functions menu for trig functions, logs, etc.  Okay 
completes the calculation and returns to the graphics screen. 
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�  
Graph Tools:   The first choice is to define a coordinate system. 

Select one point, then the choice is Define Origin and you get a square coordinate system 
centered at the selected point with the scale selected under Preferences. 

Select a circle, then the choice is Define Unit Circle and you get a coordinate system with the 
center of the circle at the origin and 1 unit = radius. 

Select a segment, then the choice is Define Unit Distance and you get a square coordinate 
system centered on the screen with 1 unit = length of segment. 

Select a point and a segment, then you also get Define Unit Distance, but the coordinate system 
is centered at the selected point. 

Select two segments, then the choice becomes Define Unit Distances and you get a rectangular 
coordinate system with the first segment the horizontal unit and the second segment the 
vertical unit. 

Select two segments and a point, then the choice is the same as above and the rectangular 
coordinate system is centered at the point. 

Select nothing, or anything else, and the choice is Define Coordinate System and you get a 
square coordinate system centered at the middle of the screen with the default unit. 

 
You can Show Grid or hide the grid.  Snap Points causes points to snap to the nearest grid point.  

This can have weird consequences if dragging items, so it 
may be preferred to turn this off by clicking on this selection.  
You can plot points.  You can change the grid form between 
square, rectangular, and polar. 
 
You can select several measurements and put them in a table 
by choosing Tabulate under the Graph menu.  The last entry 
in the table will dynamically change as you move objects.  
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To add additional lines, either double-click on the table or select the table and choose Add Table 
Data under the Graph menu.  To delete the last entry in the table, select the table and press the  - 
key or select the table and choose Remove Table Data from the Graph menu. 
 
The Help menu in GSP 4.0 will open up in Internet Explorer.  This is an applet, so it takes a little 
time to load the first time it is accessed in a session. 
 
The menus and information are fairly comprehensive, but by no means as complete as you may 
want it to be. 
 
 
 
 
 
 
This is a NEW Program, and I do not know all the answers.  Please feel free to experiment.  If 
you learn anything I don’t know, please share your knowledge. 
 
 
Before you start, go to the Edit menu and choose Preferences.  Click on the Text tab.  Make 
sure that there is a √ in the box to Show Labels Automatically For All New Points.  If there is 
not, click in this box.  Click on the Units tab.  Select centimeter and hundredths for 
measurements.  
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INITIAL INVESTIGATIONS ON TRIANGLES 
(Beginning Sketchpad) 

 
Problem #1   Attributes of triangles from three points. 
Objective:  To construct a triangle from 3 points and explore angle measures. 
 
a. Select the Point tool.  Make three points by moving to three locations on the screen and 

clicking the mouse button.  Select the arrow tool to continue. 
b. Construct a triangle by selecting all three points.  [Point at each one and click.]  Now under 

the Construct menu choose Segment.  The points will be connected in the order chosen. 
c. Measure the angles of the triangle.  [Select three points, then under the Measure menu 

choose Angle.  Now unselect the three points by clicking anywhere on the screen or 
pressing esc.] 

 Repeat this for the two remaining angles by choosing the three points in different orders. 
d. Sum the angles of the triangle by choosing Calculate under the Measure menu.  Choose 

the first measure, click on the +, choose the second measure, +, choose the third measure, 
then Okay.] 

 
e. Change the size and shape of the triangle.  

Point at one of the vertices (the arrow 
turns sideways).  Hold down the mouse 
button and drag the point on the screen.  
Release the button. 

 Notice that the measurements for the 
angles have changed.  What stayed the 
same? 

 Write two possible theorems you could 
discover from this construction. 

 
A B

C

m ACB = 61.98°

m CBA = 65.04°

m BAC = 52.98°

m BAC + m CBA + m ACB = 180.00°

 
figure 1 
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Problem #2   A triangle using a segment and a point on a parallel line 
Objective:  To explore the attributes of skewed triangles. 
a. Get a clean screen.  Under the File menu choose New Sketch.  This gives you a new screen 

to work with.  Alternatively, you can go to the Edit menu and choose Select All then 
Clear. 

b. Construct the base of the triangle using the Segment tool to draw a segment AB on the 
screen. 

c. Construct the third vertex on a line parallel to the base as follows:  use the Point tool to 
place a point C anywhere on the screen, not on the segment;  choose the arrow tool;  select 
the point and the line segment;  then under the Construct menu choose Parallel Line. 

 The parallel line should now be selected (has stripes on it) because it was the last object 
created.  Under the Construct menu choose Point On Parallel Line.  You should now 
have a dark point, D, on the parallel line.  This is a movable point — practice dragging it.  I 
usually ask students to hide point C because dragging it causes the entire line to move. 

d. Construct the rest of the triangle.  [Select the movable point on the parallel line, D, then the 
two endpoints of the segment.  Now under the Construct menu choose Segments.] 

e. Measure the length of segment AB (base of the triangle).  Measure the altitude of the 
triangle by selecting D (movable point) and segment AB, then choose Distance under the 
Measure menu. 

 Measure the area of the triangle as follows:  first select points A, B, and D, then under the 
Construct menu, choose Triangle Interior.  This interior will now be selected (colored), 
so under the Measure menu choose Area. 

A B

CD

m AB = 2.26 inches

Distance D to AB = 1.71 inches

Perimeter ADB = 6.59 inches

Area ADB = 1.94 inches2

 
figure 2 
 Measure the perimeter of the triangle.  Select the interior, then under the Measure menu 

choose Perimeter. 
 
f. Move vertex D along the parallel line.  Select point D, then hold down the mouse button 

and drag it.  Since it is a child of the parallel line, it is restricted to moving along this line.  
This is called skewing the triangle. 
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 What changes?  What stays the same?  Why? 
 
 Write a theorem.   
 
 Can you change the area without changing the perimeter?  Describe how you did it. 
 
 

CONSTRUCTING A PARALLELOGRAM USING THE DEFINITION 
(Intermediate Sketchpad) 

 
Problem #3   A quadrilateral with both pairs of opposite sides parallel 
Objective:  To find the parallelogram theorems through investigation. 

a Construct the two sides of the parallelogram, AB and BC . 
b. Select C and segment AB, under the Construct menu choose Parallel Line. 
 Select A and segment BC, then under Construct choose Parallel Line. 
c. Place a point at the intersection of the two constructed parallel lines.  This will label the 

point of intersection, D. 

A B

CD

 
figure 3 

d. We want to define the parallelogram and get rid of the rest, so hide lines DC  and AD  (but 
not point D).  Construct segments DC  and AD . 

e. Draw diagonals AC  and BD .  Label the intersection. 
 Measure segments and angles. 
 



 

Schoaff, 2002  The Geometer’s Sketchpad, p.11  

A
B

C
D

E

 
figure 4 

 Write a conjecture about segments AB , BC , CD , and DA . 

 Write a conjecture about angles ABC, BCD, CDA, and DAB. 

 Write a conjecture about segments AC , AE , EC , BD , BE , and ED . 

 Write a conjecture about angles AEB, BEC, CED, and DEA. 

 Write a conjecture about angles EAB, EBA, EBC, ECB, ECD, EDC, EDA and EAD. 
 
f. Move point B so that AB = BC.  Now what is true?  Name this shape. 
 What happened to angles AEB and BEC? 
g. Move point C so that m∠ABC = 90˚.  Now what is true?  Name this shape. 

 What happened to angles ABC, BCD, CDA, and DAB? 
h. What happened to segments AC, AE, EC, BD, BE, ED? 
i. Write at least ten theorems you think might be true about parallelograms in general and 

special parallelograms, such as rectangles, squares, and rhombi. 
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Problem #4   Basic Transformations 
Objective:  To discover the attributes of the basic transformations of reflection, translation, and 
rotation. 
 
Doing transformations and sequences of transformations are really easy with dynamic software.  
You can use the axes and grid to place points at specific locations.  Once you have constructed 
the transformation, you can move the center of rotation, mirror line, original object, etc. to see 
the impact on the final image. 
 
Construct a non-regular, preferably non-convex, polygon.  The 
more unusual the better so you can tell if it has been reversed or 
changed.  Place points on the screen using the Point tool.  Select 
them in order, then under the Construct menu choose Segment to 
create the polygon.  You may have a polygon similar to the one 
at the right. 
 
1. Reflection: 
 A reflection requires an object and a line. 
 

A

B

C

D

E

F

G

 
figure 5 

 a. Draw a line.  Select the Segment tool, then drag to the last icon to select the line (two 
arrows).  Now draw a line on the screen.  While the line is selected, under the 
Transform menu choose Mark Mirror. 

 b. Select the polygon.  You can use a marquee to encompass the entire polygon, including 
points and segments.  Using the Arrow tool, position at the upper left of the polygon, 
hold down the mouse button and drag to the bottom right of the polygon.  A dotted 
rectangle (marquee) will be drawn.  Everything inside the rectangle will be selected.  If 
the line is also selected, click on it to deselect. 

 c. Under the Transform menu choose Reflect.  (Your result should look something like 
figure 6.) 

  You can measure lengths and angles of the original and the new polygon. 
  Does reflection change the length of the sides? 
  Does reflection change the size of the angles? 
  Is the new polygon named in clockwise or counter-clockwise order?  (This is called 

orientation.)  What about the original polygon? 
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A

B

C

D

E

F

G

H

I

A’

B’

C’

D’

E’

F’
G’

 
figure 6 
 
 Check your observations by moving points on the original polygon and moving the line. 
 Under reflection, circle what remains unchanged:  lengths     angle measure     orientation 
 
 
2. Translation: 
 For a translation, you need an object and a vector or change in x and y.  For this example, 

we will use a line segment where the order in which the endpoints are named indicates the 
direction and the length. 

 a. Get rid of everything except the original polygon.  Under the Edit menu choose Undo... 
repeatedly until you are back to your original polygon.  (Or press �  - Z.) 

 b. Change the Line tool back to a segment and draw a segment.  Choose the endpoints of 
the segment.  Under the Transform menu, choose Mark Vector. 

 c. Select the polygon. 
 d. Under the Transform menu, choose Translate.  A dialog box will appear and the 

button next to Marked should be selected.  Choose Translate. 
  Does translation change the length of the sides? 
  Does translation change the size of the angles? 
  Is the new polygon named in clockwise or counter-clockwise order?  What about the 

original polygon? 



 

Schoaff, 2002  The Geometer’s Sketchpad, p.14  

 
  Check your observations by moving points on the original polygon, changing the line 

segment. 
  Under translation, circle what remains unchanged:  lengths     angle measure     

orientation 
 
 
3. Rotation: 
 For a rotation you need an object, a point for the center of the rotation, and an angle of 

rotation. 
 a. Undo back to the original polygon. 
 b. Select point A on the polygon.  Under Transform choose Mark Center. 
 c. Choose the entire polygon.  Under Transform choose Rotate.  For the angle enter –127.  

(This would be a clockwise rotation about 
1
3  around the circle.)  Your figure should 

look something like figure 7.) 

A

B

C

D

E

F

G

B’

C’

D’

E’

F’

G’

 
figure 7 
 d. Undo the rotation. 
 e. Select the angle ABC in that order.  Under Transform choose Mark Angle. 
 f. Select the entire polygon.  Under Transform choose Rotate.  This time the button next 

to Marked Angle should be selected.  Choose Rotate. 
  Does rotation change the length of the sides? 
  Does rotation change the size of the angles? 
  Is the new polygon named in clockwise or counter-clockwise order?  What about the 

original polygon? 
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 Check your observations by moving points on the original polygon. 
 Under rotation, circle what remains unchanged:  lengths     angle measure     orientation 
 
 
 
Problem #5    Connecting Algebra & Geometry — Lines 
Objective:  To illustrate geometric representations of lines and the equations of lines. 
 
1. In a new sketch, choose Define Coordinate System from the Graph menu. 
2. Draw any line.  Measure its slope using the Measure menu.  Slope = _______. 

 
figure 8 
3. Select the line itself and drag it around.  Observe the effect on its slope. 
4. Select one of the points on the line and drag this point to rotate the line.  How does this 

affect the slope? 
 a. Which lines have a positive slope and which have a negative slope? 
 b. What is the slope of a horizontal line? 
 c. How can you tell a steeper slope from a shallower slope? 
 d. What is the slope of a vertical line? 

5. Select one of the points on the line, and the line, and construct a perpendicular line.  
Measure the slope of the perpendicular.  How do the slopes compare? 

6. Select the two slope measurements and, using Calculate under the Measure menu, multiply 
these two numbers.  What is the product? 

 Drag around one of the points of the original line.  What happens to the product? 

7. Place a point on the screen that is not on any line.  Select the point and your original line 
and construct a parallel line.  Measure the slope of the parallel line.  How does the slope 
compare to the original line? 
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8. In a new sketch, choose Define Coordinate System.  Select the x-axis and construct a point 

on it.  Select the y-axis and construct a point on it. 
9. Select the two points and construct a line (not a segment) through these two points. 
10. Select the point on the y-axis and get its coordinates (under the Measure menu).  Select the 

line and measure its slope.  Also measure its equation. 
11. Drag your line and compare the three measurements.  One type of linear equation is called 

the slope-intercept equation.  A linear equation in this form looks like y = mx + b.  
Describe what m and b represent, using observations from your sketch. 

 
 
Problem #6    Creating a Tool for the Pythagorean Theorem 
Objective:  To investigate the Pythagorean Theorem as it applies to right and non-right triangles. 
 
Tools are recordings of the steps you did to create a construction.  The purpose is to allow you to 
repeat constructions on the same figure or new figures.  One method of creating a tool is to do a 
construction, highlight everything, and then under the Custom Tool icon choose Create New 
Tool. 
 

A B

C

 
figure 9 

1. Open a new sketch.  Construct a right triangle.  (One 
method is to construct segment AB, construct a ⊥ at 
A, construct a point C on the ⊥, hide the ⊥, connect C 
to the endpoints of the segment.) 

 

2. Now construct a square on side AB in the following manner.  Select A and mark as a 
center.  Select B and rotate –90˚ (clockwise). 
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3. Select B and mark as a center.  Select 
A and rotate 90˚ (counter-clockwise).  
Select A, B, A’, B’ and construct 
segments to make a square.  Click on 
A, B, A’, B’ to construct a 
quadrilateral interior. 

4. Now to create the tool, select points A, 
B, A’, B’, segments BA’, A’B’, B’A, 
and the quadrilateral interior.  Click on 
the Custom Tool icon and choose 
Create New Tool.  You can name 
your tool.  It will be added to the 
menu. 

5. To construct the other two squares, we 
will just use your tool.   

A B

C

B’ A’

A’

C’

C’

B’

 
figure 10 

 Be careful though.  If you select Show Script View in the Custom Tool menu, you can see 
the order in which the points are named in the Given section.  Mine says “1. Point B, 2. 
Point A” which means that I have to name the points in clockwise order.  If I reverse the 
order, the square will be constructed on the inside of the triangle. 

 Click on the Custom Tool icon and select your new tool.  When you move the cursor to the 
screen, it looks like an arrow with a dot on the tip.  Point to A and click, now when you 
move to C you can see the square forming.  Repeat for side CB. 

6. Now click on each of the interiors and measure the areas of the squares on the legs and the 
area of the square on the hypotenuse.  Add the two areas of the squares on the legs.  How 
does the sum compare to the area of the square on the hypotenuse? 

 Move A, B, and C to determine if this relationship will always hold. 
 
7. Get a new sketch.  Now construct any triangle ABC, then run the script to construct squares 

on the sides.  You can show that AB2 + AC2 = BC2 if and only if m∠CAB = 90˚.  For a 
non-right triangle, you would have AB2 + AC2 > BC2 or AB2 + AC2 < BC2. 

 If m∠CAB > 90˚ then BC2   <   =   >   AB2 + AC2?      (circle one) 

 If m∠CAB < 90˚ then BC2   <   =   >   AB2 + AC2?      (circle one) 

 These inequalities will eventually lead to the Law of Cosines. 
 
 
Problem #7    Locus Through Animation 
Objective:  To find the locus of points when the construction is animated. 
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In order to do animation, you need to have an object move along a path, usually a point moving 
on a line segment or circle, or randomly around the screen.  You then have the following 
choices:  object moves forward, backward, bi-directional, or random and object moves at a slow, 
medium, or fast speed.  You can trace the locus of some objects in order to see the pattern that 
occurs. 
 

1. Construction:  Draw segment QR.  Construct point T on QR .  Place a point S somewhere 
not on QR .  Construct segment TS.  Construct M, the midpoint of TS .  If point T is 
animated along segment QR, what is the locus of point M?   

figure 11 
 First select point M, then under the Display menu choose the Trace Midpoint option.  Now 

select point T.  Under the Edit menu choose Action Buttons, then Animation.  Now click 
on OK to accept the defaults. 

 Describe the tracing that results from this animation.  What is the shape?  How is it related 
to QR ? 

2. Construction:  Draw a circle with center labeled V.  Construct a point Y on the circle (do 
not use the point that defines the radius).  Draw a point X, not on the circle, and construct 
segment XY.  Construct M, the midpoint of XY . 

figure 12 

Animate Point

M

Q R

S

T

Animate Point

M

V

X

Y
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 Select point M, then under the Display menu choose the Trace Midpoint option.  Now 
select point Y and under the Edit menu choose Action Buttons, then Animation.  Now click 
on OK. 
As point Y is animated around the circle, what is the locus of point M?  How is the locus 
related to the circle and to the distance XV? 

 
 
 

Extension Problems 
 
I. Conic Sections 
 
 A. Parabolas constructed by locus definition: 
 The definition of a parabola is the set of points that are equidistant from a line (directrix) 

and a point (focus).  In figure 13, line AB is the directrix and D is the focus.  If point F is 
on the parabola, then FD = FC. 
To construct the locus of all points F, we need to observe that ∆FDC would be isosceles 
and FC⊥AB .  The following steps will construct the locus of point F. 

 

A BC

D

F

 
figure 13 
 1. Get a new sketch. 
  Draw a horizontal line, AB, at the bottom of the screen.  [Hold down the shift key while 

using the line tool to make a horizontal line.]  Select the line and construct a point on 
the line. (C) 

 2. Place a point about an inch above the line. (D) 
  Select the point C and the line AB and construct a Perpendicular line. 
  [The desired point F is located on that perpendicular.  Since this point is also the vertex 

of an isosceles triangle, then it is located on the perpendicular bisector of the base, 
CD .] 
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 3. Construct a segment joining the focus D and the point on the line C.  (CD  in my 
sketch.)  With the segment selected, construct a point at the midpoint. (E) 

 4. Select the midpoint and the line segment CD, then construct a perpendicular.  Construct 
the point F where the perpendiculars intersect.  (See figure 14.) 

 5. Select the perpendicular, EF , then under Display choose Trace Perpendicular Line.  If 
you drag C along AB  you will see shadows left of the locus of the perpendicular. 

 6. We are now ready to animate this sketch. 
  Select the point on the horizontal segment (C) and under the Display menu choose 

Animate Point. 
  What does the locus of the perpendicular bisector outline?  This is called an 

“envelope.”  Click on the | | button to stop.  Under the Display menu, choose Erase 
Traces. 

 
 
figure 14 

 7. Select the two perpendiculars (CF  and EF ), CD , and point E, then under the Display 
menu choose Hide Objects.  Choose point F, and then point C, and under Construct 
choose Locus. 

  Now you can see that as you move point C along line AB, the locus of the point will 
outline the parabola — the set of all points where FD = FC.  Your screen should look 
like the figure 15. 
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figure 15 
 8. You can change the location of the focus in relation to the directrix to determine the 

effect this distance has on the shape of the parabola.  As you move the focus D away 
from the directrix AB , how is the parabola changed? 

  As you move the focus D closer to the directrix AB , how is the parabola changed? 
 
 
 B. Graphing Parabolas using the function equation 
 A parabola is defined by the function f(x) = a x ! h( )2 + k , where the vertex is (h, k).  The 

value of a determines the shape and direction.  (Note: the following directions can easily be 
modified to illustrate the equation f(x) = ax2 + bx + c .) 

 1. Open a new sketch and choose Define Coordinate System from the Graph menu. 
 2. From the Graph menu choose New Parameter…  Change the name to a and change the 

unit to cm. 
  Repeat this step to create parameters h and k. 
 3. Select the three parameters, then under the Graph menu choose New Function…  From 

the Values submenu and the keypad, build the equation f(x) = a x ! h( )2 + k . 

 4. Select the function and choose Plot Function.  (See figure 16.) 
 5. Select parameter a.  Click on the + key to increase the value of a.  Click on the – key to 

decrease the value of a. 
  What happens to the parabola when parameter a is negative? 
  What happens to the parabola when parameter a is positive? 
  What happens to the parabola when parameter a is very large? 
  What happens to the parabola when parameter a is between 0 and 1? 
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  What happens to the parabola when parameter a is zero? 
 6. Select parameter h.  Click on the + key to increase the value of h.  Click on the – key to 

decrease the value of h. 
  What happens to the parabola when parameter h is negative? 
  What happens to the parabola when parameter h is positive? 
  What happens to the parabola when parameter h is zero? 
 

 
figure 16 
 7. Select parameter k.  Click on the + key to increase the value of k.  Click on the – key to 

decrease the value of k. 
  What happens to the parabola when parameter k is negative? 
  What happens to the parabola when parameter k is positive? 
  What happens to the parabola when parameter k is zero? 
 
Repeat this construction for f(x) = ax2 + bx + c .  When parameter a is positive, as you change 
the value of parameter b, how does the vertex of the parabola change? When parameter a is 
negative, as you change the value of parameter b, how does the vertex of the parabola change? 
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 C. Ellipses and hyperbolas — emulating wax paper folding: 
 This method was originally done with wax paper.  Students drew a circle on the wax paper 

with the center indicated, then chose a point outside the circle.  They then placed about 20 
or more points on the circle.  The point outside the circle was matched with a point on the 
circle and the wax paper was creased.  By continuing in this fashion, the hyperbola 
envelope was formed.  If the point were placed inside the circle and folding done as before, 
the ellipse envelope was formed. 

 1. Get a new sketch.  Draw a circle in the middle of the screen.  Select the circle and 
construct a point on the circle. (C) 

 2. Place a point outside the circle. (D) 
 3. Construct a segment joining the point on the circle and the point outside the circle.  

(CDin my sketch.)  With the segment selected, construct a point at the midpoint. (E) 
� 4. Select the midpoint and the line segment CD, then construct a perpendicular. 

 

figure 17 
 5. Select the perpendicular, then under Display choose Trace Perpendicular Line. 
 6. Since we want to reposition D and animate this several times, we will create an 

“Animation button”.  Select the point C on the circle.  Under Edit choose the Action 
Buttons submenu, then choose Animation.   Click on Once Only and Fast, then OK.  
You will now have a button on the screen. 
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 7. Click on the button to animate the sketch.  What does the locus of the perpendicular 
bisector outline? 

 8. Move point D inside the circle.  Click the animation button.  Now what does the locus 
of the perpendicular bisector outline? 

 9. Move point D on top of the center of the circle.  Animate again.  Now what do you 
have? 

 
 
II. TRANSFORMATIONS 
 

1.Glide Reflections — An iterated transformation 
A glide reflection is a combination of a translation and a reflection in parallel lines.  You 
can define your own compound transformations, which consist of a sequence of one or 
more basic transformations.  Follow the steps outlined below to define a glide reflection. 

 1. In one corner, out of the way, draw a horizontal segment.  (This is the vector, or delta-x 
and delta-y for our translation.)  Click on the left endpoint of the segment, then the right 
endpoint.  Under Transform choose Mark Vector. 

 2. Place a point on the left edge of the screen, halfway down.  Select the point and the line 
segment and construct a parallel line.  While the line is selected, under the Transform 
menu choose Mark Mirror. 

 3. Draw a polygon, similar to the one in Problem 4.  Construct a polygon interior. 
  Now you have a figure, a line for reflection, and a translation defined by a vector.  (You 

can also define a translation by a distance and an angle.)  Remember for a glide 
reflection, the glide should be parallel to the line of reflection. 

 
 4. Perform the reflection followed by the translation (or vice versa). 
 Reflection: 
  a. Select the polygon.  If you have selected anything extra, click to deselect. 
  b. Under Transform choose Reflect. 
 Translation 
  c. The reflected polygon should now be selected. 
  d. Under Transform choose Translate. 
  e. You will get a dialog box.  Choose Marked vector and click on Translate. 
 
 5. Select the middle polygon.  (If the polygons overlap, drag the segment to make the 

vector longer.)  Under the Display menu choose Hide Objects. 
 6. Select the vertices of the initial image, and then from the Transform menu choose 

Iterate.  From the dialog box match D to D” by clicking on point D”, match E to E” by 
clicking on the point E”, and so on for each vertex.  Then click on Iterate. 
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You now have a sequence of shapes illustrating a glide reflection. (See figure 18.) 
 
Under glide reflection, circle what remains unchanged:  lengths     angle measure     orientation 
 

�figure 18 
 

2.Your own. 
Create another two or three step transformation using some combination of reflections, 
translations, dilations, rotations, etc.  Iterate and print out the result. 
 
 

III. Fractals — The Sierpinski Gasket 
 This is a fractal that is defined as follows: divide a triangle into fourths by connecting the 

midpoints of the three sides, then remove the middle triangle.  This step is repeated on each 
of the three remaining triangles.  Create a Sierpinski gasket with the following steps. 

 1. Get a new sketch. 
  Draw three points on the screen.  Select all three points and construct a triangle.  While 

the triangle sides are selected, from the Construct choose Point at Midpoint. 
  You should now have a triangle with three midpoints, D, E, F. 
 2. Select the three vertices, A, B, C. 
  From the Transform menu choose Iterate. 
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  From the dialog box map A → A, B → F, C → E. 

  Then from the Structure submenu, choose Add New Map. 
  From the new set of mappings, map A → E, B → D, C → C. 
figure 19 
  From the Structure submenu, choose Add New Map. 
  From the new set of mappings, map A → F, B → B, C → D. 

  Then click on Iterate.  (See figure 19.) 
 
Select the fractal and press + to increase the number of iterations.  Press – to reduce the 
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iterations.  (See figure 20.) 
figure 20 
 
Koch Snowflake 
 1. Start with a new sketch.  Construct a segment. 
  Select point A and under the Transform menu, choose Mark Center. 
  Choose point B and then under Transform choose Dilate.  The ratio should be 1 to 3. 
  Repeat this choosing a ratio 2 to 3. 
 2. Choose the 1/3 point and mark as a center.  Rotate the 2/3 point by 60˚. 
  Hide segment AB.  Connect the points as in figure 21a. 

figure 21 a       b 
 3. Select points A and B.  Under Transform, choose Iterate.  Then select each of the four 

segments in turn. 
  Increase and decrease the number of iterations using the + and – keys.  (See figure 

21b.) 
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